For a better experience on dSPACE.com, enable JavaScript in your browser. Thank you!

AUTOSAR Compatibility

Compatibility with AUTOSAR Features

Please contact dSPACE for detailed information regarding the support of dedicated AUTOSAR features.

Please contact Support@dspace.de.

Supported AUTOSAR Versions

Compatibility of dSPACE software with different versions of the AUTOSAR standards.

AUTOSAR Classic

AUTOSAR Version

 

4.4.0 4.3.1 4.3.0 4.2.2 4.2.1 4.1.3 4.1.2 4.1.1 4.0.3 4.0.2 3.2.3 3.2.2 3.2.1 3.1.5 3.1.4.DAI.4 3.1.4 3.1.2 3.1.0 3.0.7 3.0.6 3.0.4 3.0.2 3.0.0 2.1.4 2.1.2 2.1.1 2.0.0 SP 3 2.0.0
SystemDesk Support started with version 5.3 5.1 4.8 4.5 4.4 4.3 4.2 4.1 4.0 4.0 No support 3.2 3.1 3.1 3.1 3.0 2.1 2.1 3.1 3.0 2.0.4 2.0 2.0 1.1 1.1 2.0 1.0 -
  Support ended with version                       3.2 3.2 3.2 3.2 3.2 3.2 3.2 3.2 3.2 3.2 3.2 2.1 3.0 2.1 2.1 1.1 -
TargetLink Support started with version 5.0 4.3p1 4.2p1 4.1p1 4.0p1 4.0 4.0 3.5 3.4 3.3p1 4.0 3.4 3.3 3.3 3.1 3.2 3.2 3.1 3.3 3.2 3.2 2.3.1 No support 2.3.1 2.3 No support 2.2.1 2.2
  Support ended with version                     4.4 4.4 4.4 4.4 3.5 4.4 4.4 4.4 4.4 4.4 4.4 4.4   4.4 3.0   3.0.1 2.2
  Exceptions        

 

 

                3.2             3.0   3.0 2.3.1      
FlexRay Configuration Package1 Support started with version 2019-A 2018-A SP1 2018-A SP1 2016-A 2015-B No support 2014-A 2013-B 2013-A No support No support 7.4 7.2 No support 7.2 7.1 No support No support No support No support No support No support No support No support No support No support No support No support
RTI CAN MM Blockset1 Support started with version 2019-A 2018-A SP1 2017-B 2016-A 2015-A No support 2014-A 2013-B 2013-A No support No support 7.4 7.3 No support 7.2 7.2 No support No support No support No support No support No support No support No support No support No support No support No support
RTI LIN MM Blockset1 Support started with version 2019-A 2018-A SP1 2017-B 2016-A 2015-A No support 2014-A 2013-B 2013-A No support No support 7.4 7.3 No support 7.2 7.2 No support No support No support No support No support No support No support No support No support No support No support No support
Bus Manager1 Support started with version 2019-A 2018-A SP1 2017-B 2016-A 2015-A No support No support No support 2015-A No support No support No support 2015-A No support No support No support No support No support No support No support No support No support No support No support No support No support No support No support

1) Version number equals dSPACE Release

AUTOSAR Adaptive

 

AUTOSAR Adaptive
Release

 

19.03
TargetLink Support started with version 5.0

Sujets apparentés Informations produit
Tags
Date 2019-11-12
Type de logiciel Logiciels de génération automatique de code série, Logiciels d’implémentation, Logiciel d’architecture système, Logiciels d’interface de bus
Sujets d’intérêt AUTOSAR
Types de protocoles/de bus CAN, FlexRay, LIN
Produit Bus Manager, dSPACE Ethernet Configuration Package, dSPACE FlexRay Configuration Package, RTI (Real-Time Interface), RTI CAN MultiMessage Blockset, RTI LIN MultiMessage Blockset, SystemDesk, TargetLink
Type d’information Informations de référence
Catégorie d’information Versions et compatibilité
Release dSPACE 2019-B, 2019-A, 2018-B, 2018-A, 2017-B , 2017-A, 2016-B, 2016-A, 2015-B, 2015-A, 2014-B, 2014-A, 2013-B, 2013-A, Avant la 2013-A