FlexRay Configuration Package 1.5.4

FlexRay Configuration Package 1.5.4 - Product Release for dSPACE Release 5.2

Introduction to FlexRay Configuration Package 1.5.4
Limitations
Installation Notes & Download

Introduction to FlexRay Configuration Package 1.5.4

This software can be installed on an existing Release 5.2 installation.


FlexRay Configuration Package 1.5.4 is not part of dSPACE Release 5.3.
The new features of FlexRay Configuration Package 1.5.4 are also contained in version 1.6 in Release 5.4.


The dSPACE FlexRay Configuration Package 1.5.4 is a bundle of two software products:

  • dSPACE FlexRay Configuration Tool 1.5.4
  • RTI FlexRay Configuration Blockset 1.5.2

Supported dSPACE Hardware

  • DS1005/ DS1006 with DS4501
  • MicroAutoBox DS1401/ DS1505/ DS1506 and DS1507
  • DS4340 FlexRay module
  • FlexIM2+, FlexIM3, FlexIM4+, FlexIM modules from DECOMSYS
  • FlexIM4+ FlexIM module from DECOMSYS with Freescale V11 IP-Core
  • FlexIM2+/4+ FlexIM modules from DECOMSYS with Bosch E-Ray IP

Supported Standards

  • FIBEX: Version 1.1.5a, 1.2, 2.0
  • FlexRay: Version 1.1 (as provided by the FlexIM modules from DECOMSYS)
  • FlexRay: Version 2.1 (as provided by DS4340 with PFR4300 and compliant FlexIM modules from DECOMSYS).

Limitations

Only single channel FlexRay systems are supported.
No fault tolerant communication code can be generated.
Editing or exporting FIBEX information is not possible.

The DS4505 FlexRay Interface Board is not supported by this Package version but it requires at least dSPACE Release 5.4.

Installation Notes & Download

FlexRayConfigurationPackage_PR_1_5_4.exe (9.82 MB)